Tommy Penner

Tommy Penner Staff

// UPDATE: 8/8/2014 - You should now see HTTPS video delivery for players loaded over HTTPS. Thanks for your patience and understanding!

Gramafilm

Gramafilm PRO

Would be really useful to have ssl support on the new embed codes. This I imagine would be especially popular for pro users who need to keep content and rough cuts safe and secure online.

Brad Dougherty

Brad Dougherty Staff

We will be adding HTTPS support, but there's no ETA at this time. A lot of things need to be upgraded to support it.

Brad Dougherty

Brad Dougherty Staff

Hey everyone,

We're really close to officially announcing this, we just need to do a bit more testing, which is where you come in!

All you have to do is change the iframe url from http to https. Please let us know if you run into any trouble.

QUENTIQ

QUENTIQ

We are getting errors on Firefox and Safari on Windows 7.

Get the following error in firefox:
You have requested an encrypted page that contains some unencrypted information. Information that you see or enter on this page could easily be read by a third party.

And the player does not show.

Works fine on XP in Firefox, Chrome etc.

site: quentiq.com/content/

embed code:

QUENTIQ

QUENTIQ

Thx for the quick reply!

Its showing up for me too, just not in FF and Safari for on Windows - they work for you?

ftplectures LLC

ftplectures LLC PRO

when will ssl support for embedded vimeo videos be avaialble?

Brad Dougherty

Brad Dougherty Staff

We haven't officially announced it yet, but everything should work just fine if you change the src of the iframe from http to https.

UKfilmNet

UKfilmNet Plus

Brad - when is this ACTUALLY going to happen? this request and thread and promises that "we're working on it" have been going on for over a year??

until then workaround please???

Brad Dougherty

Brad Dougherty Staff

Everything should work fine if you change the iframe src to https.

AppGuru

AppGuru Plus

Simply changing http to https in the iframe src doesn't work. Initially it works but after hitting play button many requests are made to insecure content triggering warning message in the browser.

Harm van de Ven

Harm van de Ven

I get the same errors as Tom.
I need SSL to create a safe looking shop. Getting an unsafe browsing experience doesn't really help.
Am I doing something wrong or is this something you are working on?

Thanks,
Harm

Link: ikstonderbij.nl

Medeo

Medeo PRO

We have this issue as well, it's fine until the user hits play. We'd really like to see a fix.
You can currently see it on the home page or the about page at medeo.ca. We'll unfortunately have to stop using Vimeo if there is no fix.

GoSkills

GoSkills PRO

I read in another thread vimeo.com/forums/help/topic:102408 that this, or at least what looks like a similar issue, will be fixed in the 'next player push'. What I'm seeing is that the player is pulling some data with https and some with http.

Can you please tell us if this is likely to be fixed in the 'next player push' and offer a rough timeframe?

Studio 7C

Studio 7C PRO

Dear Vimeo-Team:

Would you let me know what the status on this is? Any updates?

Kindly,
Dagi Cueppers

Matt Schwarz

Matt Schwarz Staff

Hey folks,

We are hoping to fix this in a new release of our player, but unfortunately we cannot provide an ETA. Soon we hope!

MediConecta

MediConecta PRO

We are also waiting for this... we can't run part of our web apps on SSL because of this.

Matt Schwarz

Matt Schwarz Staff

Our new player is now rolled out on 100% of embeds and should function with SSL using our new relative embed codes. Please try re-embedding the problem videos and see if that works!

Mentor4Managers

Mentor4Managers PRO

I am still getting security warnings using the universal embed code with SSL as the player is still loading the video file over HTTP. Please can you clarify what you mean by 'new relative embed codes' - am I missing something?

Jonathan Stray

Jonathan Stray

Yes, this is a problem for us as well -- so much so that we are switching the embedded videos to YouTube

Matt Schwarz

Matt Schwarz Staff

Hi Jonathan,

FWIW, YouTube doesn't load videos over HTTPS either. You'll still experience the same browser alerts.

LateNite Films

LateNite Films PRO

From the limited testing we did, YouTube didn't give us any browser security alerts - however Vimeo unfortunately did. It wasn't the video itself that was causing issues though - it was whatever 3rd party analytics Vimeo uses.

Brad Dougherty

Brad Dougherty Staff

Do you have the URL for the script that's causing the issue? Everything except for the video file should be returned over HTTPS.

Matt Schwarz

Matt Schwarz Staff

As Brad mentioned, we still serve videos over HTTP. We are investigating serving completely over HTTPS, but have no concrete plans.

Jonathan Stray

Jonathan Stray

Thanks for the reply, Matt. Well that's terrible news. Is there any video platform that has solved this?

Matt Schwarz

Matt Schwarz Staff

I cannot say, but we are investigating doing this ourselves!

Clubcard

Clubcard PRO

Hi,

we are having the same issue - as online store we need all Video embeds to be HTTPS compatible.

This seems a core problem that needs to be addressed especially when FAQ states that HTTPS does work with embeds.

Link: clubcard.ca

Matt Schwarz

Matt Schwarz Staff

Our embeds do work with HTTPS, the files simply serve from HTTP. At the most, this causes a browser alert, which we understand is annoying, but it does not stop playback.

some.io

some.io Plus

Hi,

we see the same issues with our site. In another forum post there was mentioned, that due to performance problems, the MP4 file would never be streamed over SSL. So I would like to know if this will be changed?

But the most disturbing problem with this issue is, that even on hovering over the embedded player, a request to the mp4 file is made over unencrypted http. This is a big problem for me, because the secure icon in the browser window changes. So the users get the impression of mixed content or even more worst: a warning.

Since the browsers are changing the behavior on mixed content frequently (f.e. Firefox at blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/ ) I would really like to see https enabled streaming or at least that on hovering over the image, there is no unencrypted request sent to the vimeo servers.

Would be great to get some feedback on this.

Thanks!

Link: some.io

Matt Schwarz

Matt Schwarz Staff

We are investigating the cost into serving completely over HTTPS for users who request it, but we have no update at this time. We understand that the way browsers handle unsecured content is inconsistent and confusing to users, so we're hoping to find a solution soon.

myTGA GmbH

myTGA GmbH PRO

Vimeo Videos over https would be really great!!!!

Gozeeky

Gozeeky PRO

Can't believe you are willing to charge your pro users for SSL. This service shouldn't be charge YouTube don't charge for this,.. Even for free users. The users that needs SSL is already paying for SSL for their server so all we need is for Vimeo team to setup HTTPS for pro users only. Of course this only my two cent if it count for anything.

Matt Schwarz

Matt Schwarz Staff

We're investigating the cost to us, not to you. We wouldn't charge members for using SSL.

Brad Dougherty

Brad Dougherty Staff

For what it's worth, YouTube does not serve video files over HTTPS either...

UoG - OpenED - ISD - Multimedia

UoG - OpenED - ISD - Multimedia PRO

While that may be the case, they have made their free solution usable within our LMS, while the paid version of Vimeo is still throwing content errors on each new load:

puu.sh/6R5py.jpg

I understand the technical point, but from a customer POV it is not particularly helpful.

Brad Dougherty

Brad Dougherty Staff

Very soon. We are working on resolving a couple issues with our CDN.

GoSkills

GoSkills PRO

Hi Brad. Any more news on the availability of this? Regards.

Brad Dougherty

Brad Dougherty Staff

We are continuing to work with our CDN to resolve some issues with their system. We hope to be able to enable it soon.

Darren Salkeld

Darren Salkeld PRO

Any updates on this? We need to be able to serve up videos on SSL checkout pages, but Vimeo player is still loading mixed content. Seems odd that this has been an issue for so long yet should be simple to fix.

Brett Anthony

Brett Anthony Plus

Any new updates on when we could possibly see this issue fixed? Something more concrete than very soon? It would just be helpful to know when you plan to have this issue resolved or at least a rough estimate timeframe. The videos play over ssl but these browser errors are a problem.

It's strange because public videos don't throw the errors but all of my domain specific videos cause the error when the mouse hovers over them.

Thanks for the support.

FX Digital

FX Digital PRO

We're doing more and more websites that use full SSL and I need a video service provider that can serve video's properly over SSL ... I have a vimeo pro account and would love to continue to have one... however this is going to soon become a big problem for me unless Vimeo actually stop talking about it, and actually start doing something to resolve this ... you cannot have a sales page with video if as soon as the video is played it throws an alert ... you have lost your potential buyers trust ....

Come on Vimeo do the right thing...

Tommy Penner

Tommy Penner Staff

As Brad said above, we're working with our CDN to resolve issues on their system. This is a global infrastructure change that affects the very core of our business (you know, playing video) so we have to be very careful and deliberate with any changes we make. We appreciate your patience in the meantime!

OpenEdge

OpenEdge PRO

Had we known this was going to be an ongoing issue for us we would have never purchased a pro account. We would like to pursue a refund and account cancellation.

Fundrise

Fundrise PRO

I would like to echo the sentiment of the many people on this thread in saying that this is a pretty burdensome issue for us as well. It would be great if you could provide at least some rough timeline as to when you expect this to be fixed. Any detriment to a user's trust is dangerous and this improvement would be much appreciated.

Deyson Ortiz

Deyson Ortiz Plus

Hello,
How will Vimeo announce when Vimeo embed and SSL will work together? I turned off my SSL until this issue is fixed since my videos would not load on https. I would love to be able to get a notification of when I can turn SSL back on.

Thank you and I look forward to the good news. :)

Brad Dougherty

Brad Dougherty Staff

Hi Deyson,

It's now supported! Please let us know if you encounter any issues.

Deyson Ortiz

Deyson Ortiz Plus

Thank you. I will give it a test tomorrow. I am using Wordpress’s Vimeo video embed feature. So I will let you know what happens. Thank you and have a great day! :)

Deyson Ortiz

Deyson Ortiz Plus

Works like a charm Brad! Thank you and have an amazing day! :)

Stepping

Stepping Plus

Just subscribed for a year!!!! Then noticed this thread. Grrr and potty language!!!

Andrew Tate

Andrew Tate Staff

For anyone who didn't catch this at the top of the thread, as of this week HTTPS iframes and onsite clips will also server the video file over HTTPS, so there shouldn't be any other issues with getting security warnings in your browser. But of course, let us know if you run into any issues.

Ipro Tech, LLC

Ipro Tech, LLC PRO

When uploading a video, the redirect_url that vimeo redirects to after video is uploaded comes from insecure url (non-SSL) when I am NOT logged into my vimeo account.

That means, that if I am a regular user using my site, the redirect_url that vimeo redirects to gets blocked in my browser because my site is SSL and the referrer is an address that is not SSL. This is a big problem for us.

Again, if I'm logged in to vimeo (I am a pro user) it works. The moment I log out, it doesn't come from SSL address anymore. I assume this is because after logging in to Vimeo, I get a cookie. The upload ticket for videos provides an upload_link_secure property that ALSO goes to Vimeo (this is what the vidoes POST to). When it posts, it ALSO sends this authentication cookie along with it, and the presence of that cookie is affecting the behavior of which address my redirect_url gets fired from.

Please advise, this is a pressing issue for us.

This conversation is missing your voice. Please join Vimeo or log in.