Ian Durkin

Ian Durkin Staff

Hello everyone, as suggested by Vimeo user, Enéas Versehgi, to solve this issue you just need to change one line:

write about:config in the address line
write dom.ipc.plugins.enabled.npswf32.dll
change its value to true

However, Vimeo staff cannot troubleshoot Firefox configurations. If you have any further issues, please contact them directly. In the meantime we are continuing to look into any possible issue on our end.

Pause Fest

Pause Fest PRO

Yeah same issue, doesn't work for me either 95% of the videos are not loading I just see the static image. The link you posted philipbloom.net/films/dslr-films/2-nights-in-mallory-square/ works fine!!!

using NVidea card, windows Vista 32 ... extensions firebug, screen capturer ... flash player latest 10.2.153.1 only plugin I have outdated is quicktime which i don't use.

flash block doesn't fix the problem for me

example of video I cannot view is
Link: vimeo.com/8721323

1012 photo

1012 photo

I changed "dom.ipc.plugins.enabled.npswf32.dll" to true, and that worked.

Thanks!

Pause Fest

Pause Fest PRO

It still wasn't working for me, I just tried suggestion above and yep I can confirm too dom.ipc.plugins.enabled.npswf32.dll
fixed the problem videos seem to play now!!!

-> dom.ipc.plugins.enabled.npswf32.dll = true

Alan Marques

Alan Marques

I have Window 7 64bit and Firefox 4.
The follwoing fix worked for me but I had to add the following line to my config as it did not exist.
dom.ipc.plugins.enabled.npswf32.dll = true

Tomasz Maciag
Posted this which was very helpful and shows how to do this.
technogadge.com/stop-plugin-container-in-firefox-4/

James Kramer

James Kramer

I added - dom.ipc.plugins.enabled.npswf32.dll as I didn't have it, I changed it to true, and vimeo videos still don't work :( any new ideas? I have windows 2000.

Markus Merz

Markus Merz

Same for me. Just tested it again with FF5
Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0

Christine L

Christine L

did the same as mentioned above and worked for me as well. (had to add the line/string manually)
Win XP, SP 3, FF4

conualfy

conualfy

Under Linux (Ubuntu 10.10), no Vimeo is playing in Firefox 4 without Flash Player. It says:

Awww, snap! This video can't be played with your current setup. Please upgrade to a modern HTML5-compliant browser or install Adobe's Flash Player.

But Firefox 4 is HTML5 compliant.

Brad Dougherty

Brad Dougherty Staff

Yeah we know this is a bit misleading and we're working on a clearer error message. It can't be played because Firefox does not support H.264 and you do not have Flash.

Maurice Paris

Maurice Paris

thought the fix to about:config works i do hate plugin container which is enable by using it but i cant use vimeo without it which suck much ass

hamlet82

hamlet82

Up to now everthing went well.
Now I do only see black screens, not even a moviestill as before.
Are you aware about that?

hamlet82

hamlet82

O.k. I have changed "dom.ipc.plugins.enabled.npswf32.dll" to "true". Now it's fine to watch videos on vimeo.
But embedded videos remain blank.

jsinmichael

jsinmichael

I just got mine to work, although it was a little choppy. I'm running OSX 10.6.7 and using Firefox 4. I have the Flashblock Add-On installed. To remedy the problem I ctrl+click'd on the Flash icon floating over the Vimeo frame and added the address to my Flashblock "white list". Hope this helps for at least some.

Pat DC

Pat DC Plus

Hi guys any luck with this?
This only started happening for me last night.
Works fine in chrome.

FF4, 64-bit machine, no flash block enabled.

Cheers Guys.

Bohdan Ganicky

Bohdan Ganicky

Hi, Vimeo doesn't work in Firefox 4 on Ubuntu linux. It keeps saying that my browser don't know HTML5 fu but that's not true: i.imgur.com/L1KBt.png Seems that there's some browser/feature sniff that fails.

Sam Morrill

Sam Morrill Staff

Hi Bohdan, you will need to install Flash if you want to use Firefox. Firefox requires WEBM, which we currently do not support.

Bohdan Ganicky

Bohdan Ganicky

I see. Firefox actually supports both Ogg and WebM. It would be more fair to say "Your browser doesn't support H.264 video" instead of "please upgrade to a modern HTML5-compliant browser or install flash..". Firefox is perfectly HTML5-compliant, just doesn't support patent encumbered video codec. Thanks! :)

Quadster

Quadster

Sigh.

Vimeo video is broken on Firefox yet again (just a black screen, no image or controls). The previous "fix" clearly didn't last long.

Seriously, this is well beyond a joke now. I'd be so embarrassed if I was offering a service to paying customers that was this poor.

There's still no feedback from Vimeo staff as to what the problem was and how it was fixed previously.

Is it really too much to ask for video to play on a site that is dedicated to playing video?

Dmitry Bezverkhiy

Dmitry Bezverkhiy

Hi.
Changing "dom.ipc.plugins.enabled.npswf32.dll" to true worked for me too. Since I'm flash developer I can't leave this parameter to true, it freezes firefox on any exception, because I'm using debug version of flash player.

Do you have any workarounds for this bug with FF4 with debug flash player on Win7 32 bit?

Markus Merz

Markus Merz

(Again) Vimeo started to NOT show videos nor video controls on vimeo.com.

Trying to see videos here:
vimeo.com/22404071

About:
Build-Identifikator: Mozilla/5.0 (Windows NT 5.0; rv:2.0) Gecko/20100101 Firefox/4.0

Still examining the issue. So far without success:

* FlashBlock: vimeo.com on whitelist
* FlashBlock: vimeocdn.com on whitelist

Will check FF4 in safe mode ...

Markus Merz

Markus Merz

No, FF4 in safe mode doesn't show video or video controls.

BTW: No entry in about:config for dom.ipc.plugins.enabled.npswf32.dll

Markus Merz

Markus Merz

"write about:config in the address line
write dom.ipc.plugins.enabled.npswf32.dll
change its value to true"

Doesn't work. Just tested it again with FF5

Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0

Willi Taylor

Willi Taylor

just seeing black where video should be. Win7 x64 SP1, FF4, integrated laptop graphics card on HP Pavilion dv6. tried both logged in and out, same result. Philip bloom video link worked. disabled add-ons and tested with same result.

via-dolorosa

via-dolorosa

Now I have the same error :-/ For three days

debenito

debenito

Any news?

For me the "fix" isnt working.
Im using Windows7 32bit and all plugins are disabled...
On chrome everything works fine

NeMe

NeMe

I have a similar problem with ff4.0 on mac OSX.5.8

Behaviour. Vimeos videos work just fine except when I click the full screen button which returns a black screen (without even the "press esc message"). On pressing esc I can hear the sound but the image is paused.

Subfader wrote

it works fine with object like here feelmybicep.com/2011/03/15/idjut-boys-girth-soup/

Confirming that the particular video works just fine on my setup

ISLAM TV AUSTRALIA

ISLAM TV AUSTRALIA

Not working for me, just black screen. really if we expect our video audience to be savvy with plugin and all the technical stuff we can kiss them goodbye. Vimeo is great and one of the best however if the old IE problem is still there then it's going to be over for Vimeo if this problem isn't sorted and I'm writing this 24 days after the original post.

Liespersecond _ L Butler

Liespersecond _ L Butler

Just adding to list. I can only see a black frame on vimeo, whether logged in or out. Videos embedded on FB and blogs are playing fine.

I have tried all the work arounds mentioned throughout the thread, but none work.
FF4
64 bit Win 7

GCN SoCal videos

GCN SoCal videos

I'll add myself to the list with just a black box. Ryan's philipbloom.net/films/dslr-films/2-nights-in-mallory-square/ link seems to work fine, Running FF4 on Win2K.

Funny thing is, vimeo videos are coming up just fine with IE6, haha!!

Created a brand new profile, no add-ons installed, just stock FF4. Plug-ins listed are:

Acrobat 9.4.0.195
DivX Player Plugin 6.1.0.0
DivX Web Player 1.4.2.7
Google Earth Plugin 1.0.0.1
Microsoft DRM 9.0.0.280
Picasa 3.0.0.0
Quicktime Plugin 7.1.6.200
Shockwave Flash 10.1.85.3
Shockwave for Director 11.5.7.609
VLC Multimedia Plug-in 1.1.4.0
Windows Media Player Plug-in DLL 3.0.2..629

First post! woohoo!

danielc56 :)

Tuga Taran

Tuga Taran

Bummer, i just signed up to Vimeo just to see black screens? Thanks, but no thanks.

Retrograph

Retrograph

Hello World !

I have a weird problem that I can't explain, my Mozilla's extensions, NoScript and Adblock, Plus are desactivated for vimeo.com , Adobe Flash Player is up to date and javascript is enabled on my browser BUT I can't play any videos on vimeo... there is only a black screen on the place of the player, no messages, no timeline, no loading bar...etc BUT sometimes I can play a video from vimeo on other websites. When i use Google Chrome there is no problem to play videos on vimeo so i guess Firefox is the problem but it's only on vimeo and i don't know why ? The only videos that i can play on vimeo with Firefox are the videos on mini-player (in the box : Vimeo developer highlights) at the right of the screen of the "Vimeo Developer API" page, I don't know if it's usefull to know that by the way...

It will be great help if someone could give me a hand.

Thank you, bye and sorry for my poor english ;)

Eric Neely

Eric Neely

Same issues as above. Example video plays okay, but all others are black screen only.

Daniel Hayek

Daniel Hayek Staff

Thanks, we've seen a big drop in reports of this after making a few changes. I'll see what else we can do to remedy this.

Christi Weber

Christi Weber

We are still having problems with Vimeo on some computers. Windows 7 64 bit, Firefox 4 and Firefox 3.6, NVidea Quadro NVS video adapter. Very few plugins - Nvidea 3D Vision, Shockwave Flash, Mozilla Default, Microsoft Office, Google update, Adobe Acrobat.

We can see the controls, start the video and hear the audio, but all we see is a bunch of green blocks moving around. No problem with IE 8.

Liespersecond _ L Butler

Liespersecond _ L Butler

I am still unable to watch any videos on the Vimeo site, I only get a black frame.

Win 7 64-bit
FF4 - black frame on vimeo - plays embedded videos fine on other sites.

chrome - plays on vimeo
IE - black frame on vimeo

other comp
vista 32-bit
FF4 - can only play embedded, black frame on vimeo

I have tried all the work-arounds, and updated flash etc as instructed, makes no difference if addons are disabled, or adblock.

Is there any news on this - it's been too long now.

Liespersecond _ L Butler

Liespersecond _ L Butler

Changing the dom.ipc.plugin.enable.npswf32.dll works now, where it made no difference before. But this isn't a solution - I need to have this set to false.

Chris Brown

Chris Brown

I get a message with TOR enabled.

"This video cannot be played with your current setup. Please upgrade to a modern browser yadda yadda yadda"

Disabling it resolves the videos.

Other Add-Ons installed and checked againsrt were Firebug, Evernote clipper, Ad Block Plus and Xmarks.

LesMads

LesMads

after the initial problems with FF4 vimeo videos played fine in FF4. but some time last week vimeo videos stopped showing again... all i see now is a black screen where the vimeo player should be. i don't even see a thumbnail image of the video.

vimeo video show and play fine on the same computer using other browsers (crhome, IE8, etc)

but in FF4 vimeo videos are just black.

Win XP (all service packs, updates)
FF 4.0
WIN 10,2,159,1

Don B

Don B

Switching dom.ipc.plugin.enable.npswf32.dll to true fixed it for me also on Win7-64.

Anyone know what this does for a non-developer setup?

Assn. of Health Care Journalists

Assn. of Health Care Journalists

Uploaded a video but all that shows is a black box where the video should be. Happens in IE 8 and FF 4.

FF extensions:
ColorZilla 2.5.5
HTTPS-Everywhere 0.9.5
MeasureIt 0.4.8

Using XP Pro SP 3
I have javascript enabled.

Link: vimeo.com/22941543

Don B

Don B

In FF, type about:config in the address bar, then press enter.

Copy dom.ipc.plugin.enable.npswf32.dll and paste it into the Filter box. It will be the only entry shown.

Double-click the word False in the last column so it changes to True. Restart FF.

This worked for me and others in this thread.

Alasdair Graham-Brown

Alasdair Graham-Brown

Hei. Just upgraded to Firefox 4 and, as everyone else also experiences, I now have a black screen on Vimeo. Flash is up to date. No FlashBlock. No 64 bit Windows. Everything just standard, except the Vimeo black screen. Can you try and solve this one.

Cliff Bingham

Cliff Bingham

see the comments about setting "dom.ipc.plugin.enable.npswf32.dll" which is in your about:config file to true

Cliff Bingham

Cliff Bingham

I have applied the "dom.ipc.plugin.enable.npswf32.dll" fix and videos work and file is still available in about:config

Lu

Lu

Tried to use the "dom.ipc.." but nothing appeared. Any other advice?

Chi Mel

Chi Mel

@Lu Just type "ipc" or "dom.ipc" in the Filter box in the "about:config" page (without the double dots at the end or the double quotes.)

Same here on a clean install of Windows 7 + SP1 + FF4 RTM
I had the same problem on IE9, but upgraded Flash to 10.2.153.1 and that fixed it for IE9, but not for FF4.
FF4 now has Flash 10.2.159.1 but still shows only a black frame for all Vimeo videos.

- "dom.ipc.plugin.enable.npswf32.dll" does not exist on clean FF4 installs, I believe it's only for FF3->4 upgrades, but you get the same behavior for "dom.ipc.plugins.enable:" If I set all the dom.ipc settings to their default value, videos play fine. However, if I disable that particular setting, videos show only a black frame. This particular setting is supposed to allow sand-boxing of every plug-in via plugin-container.exe. I applaud the initiative, but this file seems to be creating more problems than it resolves (memory hog, everything is slower in FF, crashes) so I think Vimeo videos should play regardless if sand-boxing is used or not, just like YouTube doesn't have any dependency on this setting. Actually, it's very important to disable it if you're a heavy YouTube user, or the plugin-container.exe process keeps growing to hundred of megabytes. Hopefully this feature will work a little better in FF4.

- vimeo.com/22651405 displays a black box with no HD/SD or right-click option. Changing the URL by inserting "moogaloop.swf?clip_id=" to "vimeo.com/moogaloop.swf?clip_id=22651405"; does work (in full screen as someone already mentioned.)

- The test link posted earlier "philipbloom.net/films/dslr-films/2-nights-in-mallory-square/"; does work in the same configuration where other Vimeo videos don't. None of the videos on Vimeo home page, and none of the links I get from time to time work, so I basically gave up on Vimeo videos.

I hope this help you guys fine-tune and fix this monumental bug. Keep us updated!

Brad Anderson

Brad Anderson

I'm having this issue too. I dunno that I can ad much more to this thread. My issue: in FF 4 vimeo videos that are embedded using the new embed code (the iFrame code) breaks on *some* videos. For me, the videos that break just shows a black box. Those same videos play fine if I use the old embed code (non-iFrame version).

Here is an example of the *old* code working: yamabushikennel.org/blog/?p=138

Here is an example of the *new* code breaking: yamabushikennel.org/blog/?p=103

Also, here is an example of some of the videos that are breaking above working when embedded with the *old* code: nihonken.org/forum/index.php?p=/discussion/5992/kai-ken-imports-round-iii-introducing-tora-ayu-nio-and-chibi/

Those broken videos above work fine in IE and FF3. I am running Win 7 on a 64 bit machine.

Thank you.

Cynthia Lara

Cynthia Lara

I can't play fullscreen videos in Firefox4 Mac.
Everything works fine in Chrome and Safari, but in FF4 when I go fullscreen all I can see is a black screen. Not a specific video, any vimeo video gives me this bug.

StrongView

StrongView Plus

we get a black or white screen for our videos. they never play. the OS is Windows XP and the tested browsers are IE and Firefox. I'm still waiting to hear back about any add-on's.

Was this issue ever resolved. What's the fix?

Chi Mel

Chi Mel

Hi Daniel, is there an update on your investigations?
I really spent a lot of time checking your links and other users' proposed solutions, including deleting all cookies and cache, so far to no avail.
I am currently recommending some blog sites to switch to YouTube until the issue is fixed.

By the way, the "STAFF" logo is illegible because of the font and colors chosen, you may want to upgrade it.

Markus Merz

Markus Merz

"write about:config in the address line
write dom.ipc.plugins.enabled.npswf32.dll
change its value to true"

Doesn't work. Just tested it again with FF5

Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0

Lawrence Bansbach

Lawrence Bansbach

As Subfader remarked a month ago, Vimeo's player works fine in Firefox 4 (as they are straight Flash) but embeds don't.

Poul Jensen

Poul Jensen

Just another user with black screens instead of a Vimeo player. I can confirm the observations that Subfader, Chi Mel and Brad Anderson made above about what works and what doesn't. My specs:

Firefox 4.0.1
Win 7 64-bit
Flash Player 10,2,159,1

Hoping for a fix soon, surprised that it persists after several months - seems like a serious issue.

Chris Korda

Chris Korda

I just upgraded Firefox to version 4 and I have the bug: All of the videos on the Vimeo site are showing as black rectangles without controls, so of course there's no way to play them. I upgraded two systems, one running Windows 2000, the other XP, and the problem occurs on both. Both installations have Java enabled and aren't running flash blockers. The only addons I have loaded are Adobe Shockwave 10.2 and the Quicktime plugin. Extensions: Adblock Plus 1.3.6 and some folder stuff (Go Parent Folder, Manage Folders, Show Parent Folder). Interestingly the embedded Vimeo videos on my web site are fine: they display controls and play normally.

Tom Callahan

Tom Callahan

Just adding myself to the list, no Vimeo unless I change the NPC setting, which like a lot of other people posting, I can't.

Windows 7 64-bit, happens with and without addons, and the same on 3 different computers with identical software setups.

21up

21up

Is it just the videos using the html5 embed code?

Hans Dirkse

Hans Dirkse

@Ryan Hefner

The video "2 Nights in Mallory Square" is the first one I can see in full screen.

My system:
- Ubuntu 11.04
- Firefox 4.0

If you need to know more, just ask.

21up

21up

This is definitely a problem with the vimeo html5 embed code. All my videos work using the old embed code.
Also i cannot see any videos at all on vimeo

Dmitry Bezverkhiy

Dmitry Bezverkhiy

The problem is still here.
Not working on FF4 Win7 32bit and Win7 64bit with all updates.

"dom.ipc.plugin.enable.npswf32.dll" is set to false, on developer need.

Guys this is embed code problem. With old embed code every thing is working fine.

Please, fix this. You are loosing users.

Jeannot

Jeannot

I have to say that sometimes the same problem is occuring with some youtube videos

Alder Cass

Alder Cass Plus

Since the problem is quite clearly to do with the newer embed code, I have no idea why Vimeo isn't (even so much as temporarily) falling back to the old embed code since this is affecting such a huge number of visitors/users.

Michael Sega

Michael Sega

I have been having the problem everyone else has been commenting on. Videos in all of Vimeo have a black screen-no controls-video links sent to me, on vimeo, and logged in. On firefox 4 or IE 9 Videos worked on day and then didn't. The test videos posted to this site worked fine.

Running win7 64 bit.
Never had a problem until recently.
Don't have the adblocks mentioned

Michael Sega

Michael Sega

Changed using about:config

dom.ipc.plugin.enable
dom.ipc.plugin.java.enable

from false to true and it seems now to work.

IE9 still has issue which I didn't modify, so maybe that is the issue?

Tschoepler

Tschoepler

I had a similar problem. When switching to full screen the video kept playing the audio but it showed a black screen. When I left full screen the video would just freeze. I simply updated the flash player and it seems to work now. No hacks applied and all flashblock + noscript active. although I don't block your's of course :)

Drew Schaefer

Drew Schaefer

I suggest to most of you to read Tomek's easy solution, cuz it took me two minutes to solve a problem that i'd frankly given up solving!
Thanks TOMEK the HERO...! Heh heh heh

Jeannot

Jeannot

None of the changes in about:config worked for me but I have a little trick that allow me to see the videos : in the right-button menu I select "this frame" and then "open in a new tab"

Laura McPhail

Laura McPhail

My vimeo uploads that are embedded on my personal website are not working. All I see is a black rectangle where the video should be. There are no controls, it's just solid black. These videos are very important for my business, can someone please help me figure out how to fix it???

No add-ons

Plugins include:
Version 1.1.5
iPhotoPhotocast 7.0
Java Plug-In2 for NPAPI Browsers 13.4.0
QuickTime Plug-in 7.6.6
Shockwave Flash 10.1.102.64

Sergex Sol

Sergex Sol

Hi there. Same issue here, black rectangle, no controls on FF4 win7x64. Whatever you've done till now did not fix the issue, maybe people just got sick of reporting it. Chrome and IE working fine, but I NEED THE EMBEDDING TO WORK!!! as for the moment the embedded videos are not working in ff4. Tks.

L.E. Found the old embedding code, in an option, my embeded video works. Thanks.

Daniel Hayek

Daniel Hayek Staff

Hey everyone, we are having trouble replicating this error. If there are people willing to allow us access to their machines via VNC please let us know here and we'll message you privately with details.

Rick Schmitty

Rick Schmitty

I am willing to share via VNC

FF4, Win7 x64
Flash: WIN 10,3,181,14 debugger

Flash developer, not running debugger or enabling dom.ipc is not an option

Ronny Adsetts

Ronny Adsetts

Seeing this problem as of today in FF4 on WinXP. On the Vimeo site, just get a black box for the video, no controls. Works fine in IEv8 and Safari. At least some embedded videos work such as this one:
ukclimbing.com/videos/play.php?i=575

Ronny Adsetts

Ronny Adsetts

Further follow up. Still get no video controls, only a black box, on vimeo.com when FF is run in safe mode. Creating a clean profile for FF however results in vimeo working.

The only thing I've done recently which may point to the problem is to enable cookie options in 'Flash privacy controls' so that I always get asked when a flash element wants to store date.

Will test further...

Ronny Adsetts

Ronny Adsetts

Solution: clear the cache and refresh vimeo.

Sigh.

Not sure why this is needed though...

CMBeumont

CMBeumont

Didn't know where else to put this:

Using FF 3.6.17
OS X 10.5.8
PowerPC G5

Flash Version: MAC 10,1,102,64
Debug Player: No

Addons:

Speed Dial 0.9.5.8
Greasemonkey 0.9.5
Firefox PDF Plugin for Mac OS X 1.1.3

Videos do not play at all
works fine on Safari

Vic

Vic

i want viemo on ff!!!!! fml

Manos Vasilakis

Manos Vasilakis

Are you sleeping Vimeo.Fixxxxxxxxxx the damn thing

21up

21up

still no fix for me, works on my mac in ff4 but on my windows machine running vista just get black box where video should be, all other browsers ok

Dmitry Bezverkhiy

Dmitry Bezverkhiy

FF 5 is out but the problem is not fixed.

The same problem as before
Win 7 32bit
FF 5.0
flashplayer 10.3.181.26

dom.ipc.plugin.enable.npswf32.dll false

Nuno Oliveira

Nuno Oliveira

Everything was fine with FF4, updated to 5 and now I also have this problem.

Linked and embedded videos work fine, black screen on vimeo website.

:S

David Thompson

David Thompson

**edit****

I was able to solve the issue with Firefox 5.

What I did was to kill my old profile and create a new one. I exported the bookmarks & RSS feeds, and the saved passwords.

Next, I made a new profile. I tested it here.... and I got video back.

Reimported bookmarks & all.. still works.

It appears to be a rogue add-on update. Not sure which one until I get them reinstalled. One by one. Once I get the problem back, I'll know.

My old profile had about 12 add-ons installed.

HOWEVER - restarting with the add-ons disabled DID NOT WORK.

I will say this - it was my profile that I used with Firefox 3.5, which was imported and updated.... maybe this is a clue.

Not sure until I can get the problem to arise again.

Meanwhile... export bookmarks, RSS & saved passwords, make new profile and start over.

Then make sure to turn off automatic updates for add-ons, just in case it's a weird add-on update causing this.

***end of edit****

I'm have same trouble. No Vimeo video!

Running Firefox 5, Windows 7 x64. No vimeo video just a black square where the video should be.

All OK with Chrome, but ... I'm a firefox guy.

Jimmy Deli

Jimmy Deli

At least for me, this is unrelated to which Firefox extensions are installed. Here are the steps I've taken so far:

1. Deleted my profile (C:\Users\\AppData\Roaming\Mozilla\Firefox\Profiles\qqcaizsa.default), and let Firefox recreate it for me.
2. Re-downloaded all my extensions. Restarted Firefox. Checked Vimeo, videos working.
3. Edited the "prefs.js" file in the Firefox profile directory to include all the 'user_pref("extensions.*" settings from my deleted profile. Vimeo still working.
4. Replaced the in-use prefs.js with the one from my deleted profile. Vimeo no longer working.

I'm guessing it's one of the other settings that's screwing things up. If I can remember, I will try to isolate the setting tomorrow. Here's a pastebin of my prefs.js file:

pastebin.com/LkAZbs95

Extra note - Before I deleted my profile, I tried disabling every single addon, with no luck.

Patrick W.

Patrick W.

I am still experiencing the same issue, using Firefox Nightly (currently version 7), and any other more-stable Firefox. This is really something Vimeo should fix as soon as possible, especially given that the issue apparently is there for multiple months already (unrelated to the actual Firefox version).

In my investigations, while inspecting the DOM source, I’ve found a hint about the source of the problem. Apparently the video player object gets the CSS class `r` which is defined as having an opacity of 0. As such the video player is actually loaded just fine, but just doesn’t get displayed.
Removing the class from the object, or changing the CSS rule immediately fixes the problem and shows the player – which is then working just fine.

As such, it is not a problem with the player itself, especially not of Flash Player. I guess the reason for this bug is solely due to some bad code within Vimeo, probably some unnecessary browser detection.

And to sum this up, here is a workaround for all annoyed people wanting to watch videos on Vimeo: Save a bookmarklet with the following content:

javascript:$$('.r')[0].className='';

Then just click that bookmarklet on a Vimeo video site. This should work on all versions of Firefox (at least 4+), and will remove the CSS class from the video.

Link: javascript:$$('.r')[0].className='';

Patrick W.

Patrick W.

You might want to add a `void(0);` at the end of the bookmarklet though:

javascript:$$('.r')[0].className='';void(0);

GCN SoCal videos

GCN SoCal videos

I have just let my vimeo+ subcscription expire over this issue.

danielc56 :)

Enéas Versehgi

Enéas Versehgi

THE SOLUTION IS SIMPLE AND REQUIRES NO DOWNGRADING OF FLASH PLAYER!!!

You just need to change one line,
write about:config in the address line
write dom.ipc.plugins.enabled.npswf32.dll
change its value to true

Voilá! Problem solved!

Danas

Danas

Problem not solved for MACs, cause MAC doesn't use DLL files... :(

Emanuel Gómez Miranda

Emanuel Gómez Miranda

I'm on a mac (OSX 10.6.8) and i cant get vimeo work on fullscreen since firefox4
i thought firefox 5 would have this bug noticed, but i've just updated to ff 5.0.1 and i'm having the same problems :(

Sam Morrill

Sam Morrill Staff

Please try the solution above.

Also, disable any add-ons you're running that may affect playback on Vimeo.

Danas

Danas

Sam - MACs don't use DLL files - this solution might only work for Windows...

Nicholas Austin Skinner

Nicholas Austin Skinner

Starting yesterday, my vimeo content won't play in Firefox. I think FF might have updated itself, but to be honest I can't remember. I have FF 5.0.1, running on Mac OS 10.5.8. Why the sudden failure?

Nicholas Austin Skinner

Nicholas Austin Skinner

I installed Flash Player by following the link provided in the error message, but the video still doesn't play. Very annoying

crank!

crank!

Patrick W. 's suggestion works for me, and I didn't have to enable the plugin-container from Firefox's config menu.

Danas

Danas

I'm on a MAC, OS X.5.8, FF 5.0.1
I also cannot play videos in full screen mode on Vimeo - black screen.
dll thing is for Windows - there are no DLLs on Macs

KAMEKO SUZU aka Norbert Tolle

KAMEKO SUZU aka Norbert Tolle

Firefox 5 update
Windows Vista Home and all Videos are black
Really, i can`t understand why a perfect thing must be
completely destroyed for NOTHING!
What for?
I tried everything, nothing works for me.
Vimeo is a cemetary if its impossible to watch videos, right?

Hiroyuki HARUTA

Hiroyuki HARUTA

I espouse Patrick W's opinion. and I found another way of solution until vemio staff fix this problem.

Just using one of the famous add-on "Stylish" which enable to use a user-stylesheet, and overwrite property of class"r" opacity 0 to 1.

Bellow is the style sheet code should be applied.

@-moz-document domain("vimeo.com") {
object.r { opacity:1 !important }
}

My English may be not good, but can you make out what I'm saying?

Hiroyuki HARUTA

Hiroyuki HARUTA

Vimeo site code seemed to be updated a few days before. the class r changed to class s. so if you use a user-stylesheet to solve this problem, the code you should write is below.

@-moz-document domain("vimeo.com") {
object.s { opacity:1 !important }
}

Link: alcyone.posterous.com/firefox4vimeo

Markus Merz

Markus Merz

"write about:config in the address line
write dom.ipc.plugins.enabled.npswf32.dll
change its value to true"

Doesn't work. Just tested it again with FF5

Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0

Rufus

Rufus

I am running Ubuntu 11.04 everything updated to stable releases and video won't play full screen in Firefox 5.0.

I tried the solution from patrick W. (vimeo.com/forums/topic:35904#comment_5358140) modified the code to use the .s classes instead of the .r. I also removed adblock plus.

Emanuel Gómez Miranda

Emanuel Gómez Miranda

i've just upgraded to firefox 6.0

videos still won't work fullscreen :(

i'm using a mac

Emanuel Gómez Miranda

Emanuel Gómez Miranda

OMG!
i've just upgraded my flash plugin and it seems to work ok with firefox 6.0

i can finally see vimeo on fullscreen again! :D

listenpreis

listenpreis

Same problem. Youtube plays. Vimeo suddenly not! There is not even a Flash applet loaded... just a black box! Please some help!

Firefox 6..

Mel M

Mel M

PC, Windows XP, FF 6.0.2, Adobe Flash 10.3 - can not get vimeo videos to work, just see black screen. I do not have the line suggested to put to true in my config list and no idea how to add it manually. What add-ons would affect playback on Vimeo if I were to do that suggestion? Any other help for this? Thanks!

Subfader

Subfader

FF6 and still videos don't play on vimeo. EPIC FAIL!

no.ski.CREW

no.ski.CREW

Same problem and i'm using the latest mozilla 6.0.2 . Everything is ok with Opera tho. I actually tried to add the string dom.ipc.plugins.enabled.npswf32.dll with a "true" value and it didn't work.

Subfader

Subfader

FF7 and still videos don't play on vimeo. EPIC FAIL!

ipowertechs

ipowertechs

i have develope a freescript site and also tutorial site

design tutorial and jquery tutorial and seo turorial

Link: ipowertechs.com

mambomedia

mambomedia

I did exactly the opposite
dom.ipc.plugins.enabled.npswf32.dll = false
and then it works!

Subfader

Subfader

I doubt it has anything to do with about:config settings since this only affects vimeo videos on vimeo.com and all that since FF4 (we now have FF7!)

NO OTHER FLASH PLAYER ANYWHERE ON THE WEB IS AFFECTED!

Does anyone of you vimeo guys understand what that means?

IT'S YOUR FAULT!

Kevin Tsuchida

Kevin Tsuchida

I am in a similar situation to those above. I am using Firefox 7.0.1 and I have the latest version of Flash installed. I do not see the dom.ipc.plugins.enabled.npswf32.dll in about:config so that is not an option for me.

I can view Vimeo content in both Internet Explorer and Chrome.

When I try to view the content I get the message "Sorry The creator of this video has not given you permission to embed it on this domain. This is a Vimeo Plus feature"

Since I can view the videos in Chrome and IE this is not true.

Suggestions on what I can do?

Subfader2

Subfader2

FF8 and still the same. Meanwhile I do think it has have to do with the about:config settings.
Anyway, Vimeo only!

This conversation is missing your voice. Please join Vimeo or log in.