Jovica Aleksic

Jovica Aleksic

Hi
Will there be documentation on moogalover anytime soon?
When I use fp_version=10, moogalover is loaded, and the loaded main class is LoopyAPI. I have difficulties on using the api_functions with this version - starting with api_setSize().

Also, I wonder whether "moogalover" is supposed to be an updated version of the moogaloop player/project or whether it's a new player and project , independent of moogaloop.
The API status feeds unfortunately have no updates since Nov 2010...

Jovica Aleksic

Jovica Aleksic

This happens in Flash. It's a branch anyway, I am using fp_version 9 for the srt player, but I was just wondering :)
Apparently, the context menu of Moogalover says it's Moogaloop in version 5.* right, so Moogalover is probably just a name for a span of moogaloop versions, right?

Ryan Hefner

Ryan Hefner Staff

Hey Jovica,

Could you send me a link to your project? You should definitely not be seeing Moogalover, that's only loaded within our iframe embed, not Flash. If you can send a link, I should be able to troubleshoot the issue you are having.

Also, we are launching some updated API docs soon, so please stay tuned.

Thanks, Ryan

Ryan Hefner

Ryan Hefner Staff

Hey Jovica,

I am not seeing the Moogalover being loaded. It appears like the correct SWF is being returned from this request.

Moogaloop Player v5.1.11

Although I did see this AS error pop-up that appears to be from one of your classes.

cl.ly/3f1t2O0K0E1F2e3n463R

That could be causing the issue you are seeing. I would recommend installing the debug version of the Flash Player and see if that helps resolve your issues.

adobe.com/support/flashplayer/downloads.html

Please let us know if that helps.

Thanks, Ryan

Jovica Aleksic

Jovica Aleksic

Hi guys.
Wow, Ryan, I had totally missed your answer - seems 2 years ago! well, I will check out the out-of-index error...
But, funny enough, the current error I get with debug player mentions your name, that is a local path with your personal account :
TypeError: Error #1009: Cannot access a property or method of a null object reference.
at com.vimeo.loopy::Loopy$/useHDS() (/Users/ryanhefner/Documents/public_html/loopy/src/com/video/loopy/Loopy.as (632)
at com.vimeo.loopy::Loopy/playPressedHandler() (/Users/ryanhefner/Documents/public_html/loopy/src/com/video/loopy/Loopy.as (1213)
...
So ,first time i get the error, it mentions "/Users/ryanhefner/.." etc, and i must kill the flash player process cuz even the debug message window does not respond.
Then, after refreshing the page, the errors show up without path/line infos (no more "/Users/ryanhefner/"... etc), and I can dismiss the errors as the message window remains responsive.
This has nothing to do with my old post however :)

This conversation is missing your voice. Please join Vimeo or log in.