Filip Philatz Filkovic

Filip Philatz Filkovic Plus

Hi guys, I have this annoying issue for a while now. When I export some video either from Adobe Premiere or After Effects to H264 codec it ends up being way too brighter than it should be. I have read online that it's only PC related issue, on mac, H264 works perfectly fine. Apparently it has something to do with the gamma adjustment of Windows..

I'm interested if anyone had in fact came to conclusion of this issue. Is there any way to fix this? When I manually play with the gamma and/or brightness levels on export I get some weird results, none of them match the original. It's either too dark or too bright.

also.. is there any other codec I could use for web uploading of HD videos except for h264?

Thank you very much!

Perrone Ford

Perrone Ford

Actually, you have it backwards. It's Mac that has the gamma problems, not the PC. When PC's export to h.264 they do not experience the gamma shift.

There are numerous formats you could encode to for upload to the internet, but h264 is the most universal.

If you are seeing this problem on a PC, it's because you've chosen to work in a color space or a gamma that is not the same as the h264. What color space have you chosen to work in for After Effects?

Filip Philatz Filkovic

Filip Philatz Filkovic Plus

Perrone, I don't know which color space I'm using.. but I should note that the same thing happens when I export videos using Quicktime player export option. So it's not limited just to AE.

Perrone Ford

Perrone Ford

Ok, well let's dig a bit deeper then...

1. What camera are you shooting with? What type of native footage are we talking about.

2. Are you editing that native footage in Premiere? Or are you transcoding?

3. Are you using a real monitor to evaluate your work, or are you just editing with your computer screen?

4. Before you export, how does the footage look on the waveform monitor? I find that when I am broadcast legal on the waveform, and I am using linear gamma, my exports to h.264 are dead on. It looks far too soft on my computer monitor but looks gorgeous on my broadcast monitor I use for seeing what I "REALLY" have.

Filip Philatz Filkovic

Filip Philatz Filkovic Plus

I'm shooting with Panasonic HVX200 - this certain project was shot on chroma key, so vast amounts of post production with the footage was done afterwards.

The footage was edited in premiere, afterwards exported as TGA sequence in 1920×1080 resolution - imported into AE.

I'm using double DVI monitors, I'll be screening the whole video on broadcast monitor tomorrow just to see all the colors and do some final touches on the color correction.

***

But.. I also need to note that when I export the video from After Effects in uncompressed Quicktime (or any other format for that matter), the video looks brilliant. Just as is should be. So the main problem here is not the adjustment setting of my monitors, nor the color profile in After Effects.. but the problem is simply directed towards the H264 codec which brightens up the whole video.

Perrone Ford

Perrone Ford

Ok, that makes things easier. Check to see if you get the same problem if you export to windows medai (.WMV). If you don't then you've got a codec problem. If you do, then you've got a gamma problem or something else more problematic. Can you send me a TARGA still? Let me see what I get on my system trying to go to a h264 file. But only do that if your .wmv export produces the same bad result.

ProductorMusical.es

ProductorMusical.es

I have the same problem in Premiere, I've tryed lots of diferent formats, H264, WMV, MPEG2 and Quicktime (with diferent codecs). But If I export in AE I dont have that issue :S

Ricardo Tabosa - Senior Editor

Ricardo Tabosa - Senior Editor Plus

I use Apple Compressor to export h.264.
After a few exporting testes, i use a 1.11 ajust in gamma to fix the problem.
In the export settings, gamma option is usally categorized as "effect".
With quicktime pro that as no gamma option i use "brightness and contrast" and "Hue&Saturation":
plus 5/8 in contrast
minus 5/8 in brightness
plus 5 saturation

Do your own tests and compare with the original.

Hope this is helpfull.

MINDRIOT PRODUCTIONS

MINDRIOT PRODUCTIONS PRO

THANK YOU!!!
I just tried both your tip to adjust the export setting in Compressor and the below link to Video Copilot. I have to say your tip worked best. Thank you so much.

John Strong

John Strong PRO

Thank you sir

After 4 years, do you still find these options to be the best workaround?

P.S. Between Apple Compressor and Quicktime Pro, do you think one yields better results than other or are they nearly identical?

Sekta Creations

Sekta Creations

a bit of info - if someone finds it somehow usable.

When i change my filmed .mp4 files to .mov via MPEG Streamclip, use those in AP, then export final media back to .mp4 [using h.264 both times - in Streamclip and AP] I get no brightness changes [or they are unnoticable].

zap znox

zap znox

i convert, mts to avi in after effects and AP only respects the gamma with .mov like sekta comented but if i try to change the mov to mp4 or another format (in AP) i get gamma shifting.
the mov is a good solution but i need it on a more friendly pc format for distribuiting.

Hugo Arcier

Hugo Arcier Plus

I have the same brightness problem when I export H264 (I am on PC). the video is too bright and I have not found the solution.

Hugo Arcier

Hugo Arcier Plus

To be more specific with this problem I notice that it appears when I read the video with quicktime and if I put the video online on vimeo but if I read the same video with windows media player it is good.

Hugo Arcier

Hugo Arcier Plus

thank you Kain&Abel, unfortunatly this doesnt works for me. The transparency slider doesnt work, it has no effect.
I am using quicktime 7.6.9 pro on windows 7 64bit.

Lin Li

Lin Li Plus

I have had a similar problem. I edited and exported to Vimeo using FCP, but when my videos on Vimeo are viewed using Windows, they appear too bright. There are many images which I have set to be high in contrast with very dark areas, but when the Vimeo file is viewed using Windows what appears to be completely black on my Mac monitor shows up with all sorts of details which I do not want. I simply do not know how to tackle this issue apart from making all the images darker but then they may appear too dark when viewed using a Mac.

wouter wynen

wouter wynen Plus

I have the same problem. Video looks fine in premiere (also on wafeform monitor), looks fine when I play the exported mp4 file with mediaplayer on windows, look fine when uploaded to youtube.

When uploaded to vimeo, black now gets dark grey, everything brightens up and loses contrast. It looks like the 0-255 values are being mapped to 16-235, so all black that should be 0-0-0 rgb now becomes 16-16-16 rgb value.

1 or 2 years ago, when you had the option on vimeo to use flash or html player, the flash player showed the correct video, with the html player it became too bright. Now that option is gone, it is default html player, and video is always too bright.

Nowawes

Nowawes

i have exactly the same prob like "wouter wynen" was writing! BUT only in chrome and firefox! ie11 (win8.1) works fine!

Jason Kraynek

Jason Kraynek PRO

Chrome does look better then safari though the color/gamma shift is still not what is on my desktop/Adobe workflow

William Fanelli

William Fanelli Plus

Same problem, on windows.
H264 exported with premiere (mainconcept codec), good on PC, good on youtube and also the vimeo preview is good, but when you play, all is brighter

François Guinaudeau

François Guinaudeau Plus

Same problem for me and I never found how to solve this problem. However, I found that most of the people who are on windows 7 have this problem when reading video from vimeo, vlc or quicktime.
This works fine on windows media player or in adobe softwares (the scopes are good too).

Rui Pinto

Rui Pinto

Same problem here....it seems this a well known problem, but there are few solutions out there.

Tony

Tony

Had same problem with contrast in premiere while exporting.
Solved it using encoder - h264 works fine with it.

Perrone Ford

Perrone Ford

The reason this is a consistent and persistent problem is that of varying gamma. PC's and Macs use different gamma. This is not under the control of the person creating the video. Thus one will always be too bright or too dark depending on what you are using to look at it.

To compound matters, Vimeo and YT seem to use different gammas as well. So a Mac video on YT may be MUCH darker than a PC video on Vimeo, etc. I offer that as an anecdote. I am not saying those combinations actually work that way.

I would suggest taking a 10 second video, moving it through your normal workflow, posting it on YT and Vimeo, and see what your results are. View the videos on both Mac's and PCs if you can. Also look at them on phones, tablets, etc. Take notes if you must. But only in this way will you be able to produce video that looks acceptable for the various platforms. I keep presets in my encoder software (Sorenson Squeeze) that tailor the video based on it's destination.

pavel.3dtv

pavel.3dtv

CG exported from after effects or premiere becomes brighten on vimeo. Black color becomes grey.
Platform: PC/windows
Codec: mainconcept h.264
No gamma applied.

Vlad Dimov

Vlad Dimov

It's not a problem with the codec but the Luminance settings of the video card guys:

1.) Click Start, then the Control Panel (if you can see the NVIDIA Control Panel icon then skip to 3.)

2.) Under View by: select Category then Large icons.

3.) Click the NVIDIA Control Panel then under Video select Adjust video color settings.

4.) Click the button for With the NVIDIA settings then select the Advanced tab.

5.) Under Dynamic Range select Full (0-255).

6.) Select the Gamma tab and make sure all three ranges are set to 1.00

7.) Finally, select the Color tab and check that:

Brightness = 50%
Contrast = 50%
Hue = 179
Saturation = 50%

When you’re done go to the lower right corner of the NVIDIA window and click Apply. Wait for the Apply button to disappear then close the Control Panels and you’re done.

Rakhas

Rakhas

Thank you Vlad! it Works.

This conversation is missing your voice. Please join Vimeo or log in.